マルチキャストパケットを特定端末だけに配信(IGMP Snooping) : コマンド設定

管理番号:YMHSW-4381

本設定例の対応機種は、SWX2310P-28GTSWX2310P-18GSWX2310P-10GSWX2300-24GSWX2300-16GSWX2300-8Gです。

図 マルチキャストパケットを特定端末だけに配信(IGMP Snooping) : コマンド設定

インテリジェントL2スイッチの IGMP Snooping機能を使用して、特定の端末だけにマルチキャストパケットを配信する設定例です。

一般的に、L2スイッチは、マルチキャストパケットをVLAN単位で配信します。そのため、VLAN内にマルチキャストパケットを受信したい端末が1台でも存在すると、同一VLAN内のすべてのポートにパケットを配信することになります。
この機能を使用することで、余分なマルチキャストのフラッディングを制御し、ネットワークの帯域幅の消費を抑えることができます。

技術情報:IGMP Snooping (SWX2310PSWX2300

スイッチの設定例

※ネットワーク機器を安全にお使いいただくために、管理パスワードの変更を奨励します。

SWX2310Pの場合

下記の設定(Config)を取り出すことができます。

設定手順

  1. ユーザモードから特権EXECモードに移行します。
    [コンソール]
    SWX2310P>enable
    SWX2310P#
    
  2. グローバルコンフィグレーションモードに移行します。
    [コンソール]
    SWX2310P#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    SWX2310P(config)#
    
  3. VLANを定義します。
    [コンソール]
    SWX2310P(config)#vlan database
    SWX2310P(config-vlan)#vlan 10
    SWX2310P(config-vlan)#exit
    SWX2310P(config)#
    
  4. IGMP Snoopingを設定します。
    [コンソール]
    SWX2310P(config)#interface vlan10
    SWX2310P(config-if)#ip igmp snooping enable
    SWX2310P(config-if)#exit
    SWX2310P(config)#
    
    [補足]
    デフォルト値のため、特に設定の必要はありませんが、明示的に記載しています。
  5. ポート1~4をアクセスポートに設定し、VLAN #10 に所属させます。
    [コンソール]
    SWX2310P(config)#interface port1.1
    SWX2310P(config-if)#switchport mode access
    SWX2310P(config-if)#switchport access vlan 10
    SWX2310P(config-if)#exit
    SWX2310P(config)#interface port1.2
    SWX2310P(config-if)#switchport mode access
    SWX2310P(config-if)#switchport access vlan 10
    SWX2310P(config-if)#exit
    SWX2310P(config)#interface port1.3
    SWX2310P(config-if)#switchport mode access
    SWX2310P(config-if)#switchport access vlan 10
    SWX2310P(config-if)#exit
    SWX2310P(config)#interface port1.4
    SWX2310P(config-if)#switchport mode access
    SWX2310P(config-if)#switchport access vlan 10
    SWX2310P(config-if)#exit
    SWX2310P(config)#
    

設定内容

VLANの設定 vlan database
  vlan 10
  exit
interface port1.1
  switchport mode access
  switchport access vlan 10
  exit
interface port1.2
  switchport mode access
  switchport access vlan 10
  exit
interface port1.3
  switchport mode access
  switchport access vlan 10
  exit
interface port1.4
  switchport mode access
  switchport access vlan 10
  exit
IGMP Snoopingの設定 interface vlan10
  ip igmp snooping enable
  exit

設定の確認

「show ip igmp snooping groups」コマンドで設定を確認します。

[コンソール]
SWX2310P#show ip igmp snooping groups
IGMP Snooping Group Membership
Group source list: (R - Remote, S - Static)
Vlan   Group/Source Address    Interface      Flags   Uptime     Expires  Last Reporter   Version
10     234.56.78.90             port1.4        R      01:08:07   00:00:44 192.168.100.20    V3
SWX2310P#
[解説]
マルチキャストパケットが配信されているポートが"Interface"に表示されます。コマンドの詳細は、IGMPグループメンバーシップ情報の表示をご覧ください。
SWX2300の場合

下記の設定(Config)を取り出すことができます。

設定手順

  1. ユーザモードから特権EXECモードに移行します。
    [コンソール]
    SWX2300>enable
    SWX2300#
    
  2. グローバルコンフィグレーションモードに移行します。
    [コンソール]
    SWX2300#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    SWX2300(config)#
    
  3. VLANを定義します。
    [コンソール]
    SWX2300(config)#vlan database
    SWX2300(config-vlan)#vlan 10
    SWX2300(config-vlan)#exit
    SWX2300(config)#
    
  4. IGMP Snoopingを設定します。
    [コンソール]
    SWX2300(config)#interface vlan0.10
    SWX2300(config-if)#igmp snooping
    SWX2300(config-if)#exit
    SWX2300(config)#
    
    [補足]
    デフォルト値のため、特に設定の必要はありませんが、明示的に記載しています。
  5. ポート1~4をアクセスポートに設定し、VLAN #10 に所属させます。
    [コンソール]
    SWX2300(config)#interface ge1
    SWX2300(config-if)#switchport mode access
    SWX2300(config-if)#switchport access vlan 10
    SWX2300(config-if)#exit
    SWX2300(config)#interface ge2
    SWX2300(config-if)#switchport mode access
    SWX2300(config-if)#switchport access vlan 10
    SWX2300(config-if)#exit
    SWX2300(config)#interface ge3
    SWX2300(config-if)#switchport mode access
    SWX2300(config-if)#switchport access vlan 10
    SWX2300(config-if)#exit
    SWX2300(config)#interface ge4
    SWX2300(config-if)#switchport mode access
    SWX2300(config-if)#switchport access vlan 10
    SWX2300(config-if)#exit
    SWX2300(config)#
    

設定内容

VLANの設定 vlan database
  vlan 10
  exit
interface ge1
  switchport mode access
  switchport access vlan 10
  exit
interface ge2
  switchport mode access
  switchport access vlan 10
  exit
interface ge3
  switchport mode access
  switchport access vlan 10
  exit
interface ge4
  switchport mode access
  switchport access vlan 10
  exit
IGMP Snoopingの設定 interface vlan0.10
  igmp snooping
  exit

設定の確認

「show igmp snooping groups」コマンドで設定を確認します。

[コンソール]
SWX2300#show igmp snooping groups
IGMP Connected Group Membership
Group Address    Interface            Uptime   Expires  Last Reporter
234.56.78.90     ge4                  00:00:59  stopped 192.168.100.20
SWX2300#
[解説]
マルチキャストパケットが配信されているポートが"Interface"に表示されます。コマンドの詳細は、IGMPグループメンバーシップ情報の表示をご覧ください。

【ご注意】
本設定例は、設定の参考例を示したもので、動作を保証するものではございません。
ご利用いただく際には、十分に評価・検証を実施してください。