障害対策と通信負荷の分散(LANポート / リンクアグリゲーション) : コマンド設定

管理番号:YMHSW-4352

本設定例の対応機種は、SWX2310P-28GTSWX2310P-18GSWX2310P-10GSWX2300-24GSWX2300-16GSWX2300-8Gです。

図 障害対策と通信負荷の分散(LANポート / リンクアグリゲーション) : コマンド設定

インテリジェントL2スイッチのリンクアグリゲーション機能を使用すると、スイッチ間を接続する複数のLANポートを束ねて、1つの論理インターフェースとして扱うことができます。束ねた回線内で通信を分散させることができるため、複数の通信が発生する場合に有効です。また、束ねたうちの1つのLANポートで障害が発生し、通信不可になった場合でも、残りのポートで通信を継続できます。

技術情報:リンクアグリケーション (SWX2310PSWX2300

本設定例では、以下の構成で説明します。

  • スイッチ(1)(2)
    - ポート1~2:VLAN #100に設定
    - ポート3~5:VLAN #100に設定。論理インターフェース #2(スタティック リンクアグリゲーション)に設定

スイッチの設定例

※ネットワーク機器を安全にお使いいただくために、管理パスワードの変更を奨励します。

SWX2310Pの場合

下記の設定(Config)を取り出すことができます。

設定手順

  1. ユーザモードから特権EXECモードに移行します。
    [コンソール]
    SWX2310P>enable
    SWX2310P#
    
  2. グローバルコンフィグレーションモードに移行します。
    [コンソール]
    SWX2310P#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    SWX2310P(config)#
    
  3. VLANを定義します。
    [コンソール]
    SWX2310P(config)#vlan database
    SWX2310P(config-vlan)#vlan 100
    SWX2310P(config-vlan)#exit
    SWX2310P(config)#
    
  4. ポート1~2をアクセスポートに設定し、VLAN #100 に所属させます。
    [コンソール]
    SWX2310P(config)#interface port1.1
    SWX2310P(config-if)#switchport access vlan 100
    SWX2310P(config-if)#exit
    SWX2310P(config)#interface port1.2
    SWX2310P(config-if)#switchport access vlan 100
    SWX2310P(config-if)#exit
    SWX2310P(config)#
    
  5. ポート3~5 をアクセスポートに設定し、VLAN #100 と 論理インターフェース #2 に所属させます。
    [コンソール]
    SWX2310P(config)#interface port1.3
    SWX2310P(config-if)#switchport access vlan 100
    SWX2310P(config-if)#static-channel-group 2
    SWX2310P(config-if)#exit
    SWX2310P(config)#interface port1.4
    SWX2310P(config-if)#switchport access vlan 100
    SWX2310P(config-if)#static-channel-group 2
    SWX2310P(config-if)#exit
    SWX2310P(config)#interface port1.5
    SWX2310P(config-if)#switchport access vlan 100
    SWX2310P(config-if)#static-channel-group 2
    SWX2310P(config-if)#exit
    SWX2310P(config)#
    
  6. 論理インターフェース #2 を有効化します。
    [コンソール]
    SWX2310P(config)#interface sa2
    
    SWX2310P(config-if)#no shutdown
    SWX2310P(config-if)#exit
    SWX2310P(config)#exit
    SWX2310P#
    

設定内容

リンクアグリゲーションの設定 vlan database
  vlan 100
  exit
interface port1.1
  switchport access vlan 100
  exit
interface port1.2
  switchport access vlan 100
  exit
interface port1.3
  switchport access vlan 100
  static-channel-group 2
  exit
interface port1.4
  switchport access vlan 100
  static-channel-group 2
  exit
interface port1.5
  switchport access vlan 100
  static-channel-group 2
  exit
interface sa2
  no shutdown
  exit
exit

設定の確認

・「show static-channel-group」コマンドで設定を確認します。

[コンソール]
SWX2310P#show static-channel-group
% Static Aggregator: sa2
% Load balancing: src-dst-mac
% Member:
   port1.3
   port1.4
   port1.5
[解説]
論理インターフェース #2に設定された、スタティック論理インターフェースの状態を確認します。
論理インターフェース #2には、メンバーとして、ポート3, 4, 5が所属しています。 コマンドの詳細は、スタティック論理インターフェースの状態表示をご覧ください。

・「show interface」コマンドで設定を確認します。

[コンソール]
SWX2310P#show interface sa2
Interface sa2
  Link is UP ★
  Hardware is AGGREGATE ★
  ifIndex 4502, MRU 1522
  Vlan info :
    Switchport mode        : access
    Ingress filter         : enable
    Acceptable frame types : all
    Default Vlan           :  100
    Configured Vlans       :  100
  Interface counter:
    input  packets          : 14
           bytes            : 1722
           multicast packets: 14
    output packets          : 21
           bytes            : 2987
           multicast packets: 12
           broadcast packets: 9
           drop packets     : 0
[解説]
論理インターフェース #2の状態を確認します。
論理インターフェース #2は、リンクアップしています。
また、物理インターフェースは"AGGREGATE"となります。 コマンドの詳細は、インターフェースの状態表示をご覧ください。
SWX2300の場合

下記の設定(Config)を取り出すことができます。

設定手順

  1. ユーザモードから特権EXECモードに移行します。
    [コンソール]
    SWX2300>enable
    SWX2300#
    
  2. グローバルコンフィグレーションモードに移行します。
    [コンソール]
    SWX2300#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    SWX2300(config)#
    
  3. VLANを定義します。
    [コンソール]
    SWX2300(config)#vlan database
    SWX2300(config-vlan)#vlan 100
    SWX2300(config-vlan)#exit
    SWX2300(config)#
    
  4. ポート1~2をアクセスポートに設定し、VLAN #100 に所属させます。
    [コンソール]
    SWX2300(config)#interface ge1
    SWX2300(config-if)#switchport access vlan 100
    SWX2300(config-if)#exit
    SWX2300(config)#interface ge2
    SWX2300(config-if)#switchport access vlan 100
    SWX2300(config-if)#exit
    SWX2300(config)#
    
  5. ポート3~5 をアクセスポートに設定し、VLAN #100 と 論理インターフェース #2 に所属させます。
    [コンソール]
    SWX2300(config)#interface ge3
    SWX2300(config-if)#switchport access vlan 100
    SWX2300(config-if)#static-channel-group 2
    SWX2300(config-if)#exit
    SWX2300(config)#interface ge4
    SWX2300(config-if)#switchport access vlan 100
    SWX2300(config-if)#static-channel-group 2
    SWX2300(config-if)#exit
    SWX2300(config)#interface ge5
    SWX2300(config-if)#switchport access vlan 100
    SWX2300(config-if)#static-channel-group 2
    SWX2300(config-if)#exit
    SWX2300(config)#
    
  6. 論理インターフェース #2 を有効化します。
    [コンソール]
    SWX2300(config)#interface sa2
    
    SWX2300(config-if)#no shutdown
    SWX2300(config-if)#exit
    SWX2300(config)#exit
    SWX2300#
    

設定内容

リンクアグリゲーションの設定 vlan database
  vlan 100
  exit
interface ge1
  switchport access vlan 100
  exit
interface ge2
  switchport access vlan 100
  exit
interface ge3
  switchport access vlan 100
  static-channel-group 2
  exit
interface ge4
  switchport access vlan 100
  static-channel-group 2
  exit
interface ge5
  switchport access vlan 100
  static-channel-group 2
  exit
interface sa2
  no shutdown
  exit
exit

設定の確認

・「show static-channel-group」コマンドで設定を確認します。

[コンソール]
SWX2300#show static-channel-group
% Static Aggregator: sa2
% Load balancing: src-dst-mac
% Member:
   ge3
   ge4
   ge5
[解説]
論理インターフェース #2に設定された、スタティック論理インターフェースの状態を確認します。
論理インターフェース #2には、メンバーとして、ポート3, 4, 5が所属しています。 コマンドの詳細は、スタティック論理インターフェースの状態表示をご覧ください。

・「show interface」コマンドで設定を確認します。

[コンソール]
SWX2300#show interface sa2
Interface sa2
  Link is UP ★
  Hardware is AGGREGATE ★
  ifIndex 66, MRU 1522
  Interface counter:
    input  packets          : 14
           bytes            : 1722
           multicast packets: 14
    output packets          : 21
           bytes            : 2987
           multicast packets: 12
           broadcast packets: 9
SWX2300#
[解説]
論理インターフェース #2の状態を確認します。
論理インターフェース #2は、リンクアップしています。
また、物理インターフェースは"AGGREGATE"となります。 コマンドの詳細は、インターフェースの状態表示をご覧ください。

【ご注意】
本設定例は、設定の参考例を示したもので、動作を保証するものではございません。
ご利用いただく際には、十分に評価・検証を実施してください。

メール

ご相談・お問い合わせ