ポリサーによるQoS処理で特定の通信が使用できる帯域を保証する

管理番号:YMHSW-24253

設定概要

リアルタイムな処理が必要な通信と、通常の情報系の通信が混在するネットワークを最適化する設定例です。
広域イーサネットで拠点間接続をしているネットワークにて、音声通信の優先制御、特定の通信の帯域保証を実現します。

本設定例は、DiffServeベースのQoSを使用して、音声通信を優先させます。
さらに、サーバーの通信は、20Mbpsの帯域を確保(保証)します(最大30Mbps)。
ネットワークが混雑している場合であっても、サーバーの通信において一定の通信速度を保証し、遅延を防ぎます。

構成図

本設定例では、以下の構成で説明します。

  • 本社スイッチ
    - ポート1
      - 各拠点からの音声通信の優先制御
      - サーバー間の通信の帯域保証 (20Mbps)
    - ポート2
      - VLAN#110
          IPアドレス:192.168.110.1/24
    - ポート3
      - VLAN#10
  • 拠点スイッチ(1)
    - ポート2
      - VLAN#120
          IPアドレス:192.168.120.1/24
      - 音声通信の優先制御
    - ポート3
      - VLAN#10
      - サーバー間の通信の帯域保証 (20Mbps)
  • 拠点スイッチ(2)
    - ポート2
      - VLAN#130
          IPアドレス:192.168.130.1/24
      - 音声通信の優先制御
    - ポート3
      - VLAN#10
      - サーバー間の通信の帯域保証 (20Mbps)

対応機種

10ギガビット/マルチギガビットスイッチ ギガビットスイッチ
L3スイッチ SWX3220 SWX3200 SWX3100
インテリジェントL2スイッチ SWX2322P SWX2320 SWX2310P SWX2310

技術情報

10ギガビット/マルチギガビットスイッチ ギガビットスイッチ
QoS SWX3220 SWX3200 SWX3100
SWX2322P SWX2320 SWX2310P SWX2310
VLAN SWX3220 SWX3200 SWX3100
SWX2322P SWX2320 SWX2310P SWX2310
アクセスリスト SWX3220 SWX3200 SWX3100
SWX2322P SWX2320 SWX2310P SWX2310

スイッチの設定例

本社 スイッチ の設定

設定内容

ゲートウェイの設定 ip route 192.168.120.0/24 192.168.2.2
ip route 192.168.130.0/24 192.168.2.3
VLANインターフェースの設定 vlan database
  vlan 2 name VLAN0002
  vlan 10 name VLAN0010
  vlan 110 name VLAN0110

interface port1.1
  switchport mode trunk
  switchport trunk allowed vlan add 10
  switchport trunk native vlan 2
  exit
interface port1.2
  switchport mode access
  switchport access vlan 110
  exit
interface port1.3
  switchport mode access
  switchport access vlan 10
  exit
interface vlan2
  ip address 192.168.2.1/24
  exit
interface vlan110
  ip address 192.168.110.1/24
  exit
QoSの設定 qos enable

access-list 1 10 permit udp 192.168.120.0 0.0.0.255 eq 5004 192.168.110.0 0.0.0.255 eq 5004
access-list 2 10 permit udp 192.168.130.0 0.0.0.255 eq 5004 192.168.110.0 0.0.0.255 eq 5004
access-list 3 10 permit any 192.168.10.0 0.0.0.255 192.168.10.0 0.0.0.255

class-map class-phone1
  match access-list 1
  exit
class-map class-phone2
  match access-list 2
  exit
class-map  class-confidential
  match access-list 3
  exit

policy-map pmap1
  class class-phone1
    set ip-dscp 40
  class class-phone2
    set ip-dscp 40
  class class-confidential
    set ip-dscp 32
    police twin-rate 20000 30000 10240 10240 yellow-action remark red-action drop
    remark-map yellow ip-dscp 8
    exit
  exit

interface port1.1
  service-policy input pmap1
  exit
スパニングツリーの設定 spanning-tree shutdown

設定の確認

「show policy-map」コマンドで設定を確認します。

[コンソール]
SWX3220#show policy-map

  Policy-Map Name: pmap1
    State: attached

    Class-Map Name: class-phone1
      Match Access-List: 1
      Set IP DSCP: 40

    Class-Map Name: class-phone2
      Match Access-List: 2
      Set IP DSCP: 40

    Class-Map Name: class-confidential
      Match Access-List: 3
      Set IP DSCP: 32
      Police: Mode: TrTCM
              average rate (20000 Kbits/sec)
              peak rate (30000 Kbits/sec)
              burst size (10240 KBytes)
              peak burst size (10240 KBytes)
              yellow-action (Remark [DSCP:8])
              red-action (Drop)
[解説]
ポリシーマップ情報を確認します。
適用されているポリシーマップ「pmap1」の詳細が確認できます。
コマンドの詳細は、ポリシーマップ情報の表示をご覧ください。
拠点1 スイッチ(1) の設定

設定内容

ゲートウェイの設定 ip route 0.0.0.0/0 192.168.2.1
VLANインターフェースの設定 vlan database
  vlan 2 name VLAN0002
  vlan 10 name VLAN0010
  vlan 120 name VLAN0120
  exit

interface port1.1
  switchport mode trunk
  switchport trunk allowed vlan add 10
  switchport trunk native vlan 2
  exit
interface port1.2
  switchport mode access
  switchport access vlan 120
  exit
interface port1.3
  switchport mode access
  switchport access vlan 10
  exit
interface vlan2
  ip address 192.168.2.2/24
  exit
interface vlan120
  ip address 192.168.120.1/24
  exit
QoSの設定 qos enable
ip forwarding enable

access-list 1 10 permit udp 192.168.120.0 0.0.0.255 eq 5004 192.168.110.0 0.0.0.255 eq 5004
access-list 2 10 permit any 192.168.10.0 0.0.0.255 192.168.10.0 0.0.0.255

class-map class-phone
  match access-list 1
  exit
class-map class-confidential
  match access-list 2
  exit

policy-map pmap1
  class class-phone
    set ip-dscp 40
    exit
  exit
policy-map pmap2
  class class-confidential
    set ip-dscp 32
    police twin-rate 20000 30000 10240 10240 yellow-action remark red-action drop
    remark-map yellow ip-dscp 8
    exit
  exit

interface port1.2
  service-policy input pmap1
  exit
interface port1.3
  service-policy input pmap2
  exit
スパニングツリーの設定 spanning-tree shutdown

設定の確認

「show policy-map」コマンドで設定を確認します。

[コンソール]
SWX2320#show policy-map

  Policy-Map Name: pmap1
    State: attached

    Class-Map Name: class-phone
      Match Access-List: 1
      Set IP DSCP: 40

  Policy-Map Name: pmap2
    State: attached

    Class-Map Name: class-confidential
      Match Access-List: 2
      Set IP DSCP: 32
      Police: Mode: TrTCM
              average rate (20000 Kbits/sec)
              peak rate (30000 Kbits/sec)
              burst size (10240 KBytes)
              peak burst size (10240 KBytes)
              yellow-action (Remark [DSCP:8])
              red-action (Drop)
[解説]
ポリシーマップ情報を確認します。
適用されているポリシーマップ「pmap1」および「pmap2」の詳細が確認できます。
コマンドの詳細は、ポリシーマップ情報の表示をご覧ください。
拠点2 スイッチ(2) の設定

設定内容

ゲートウェイの設定 ip route 0.0.0.0/0 192.168.3.1
VLANインターフェースの設定 vlan database
  vlan 2 name VLAN0002
  vlan 10 name VLAN0010
  vlan 130 name VLAN0130
  exit

interface port1.1
  switchport mode trunk
  switchport trunk allowed vlan add 10
  switchport trunk native vlan 2
  exit
interface port1.2
  switchport mode access
  switchport access vlan 130
  exit
interface port1.3
  switchport mode access
  switchport access vlan 10
  exit
interface vlan2
  ip address 192.168.2.3/24
  exit
interface vlan130
  ip address 192.168.130.1/24
  exit
QoSの設定 qos enable
ip forwarding enable

access-list 1 10 permit udp 192.168.130.0 0.0.0.255 eq 5004 192.168.110.0 0.0.0.255 eq 5004
access-list 2 10 permit any 192.168.10.0 0.0.0.255 192.168.10.0 0.0.0.255

class-map class-phone
  match access-list 1
  exit
class-map class-confidential
  match access-list 2
  exit

policy-map pmap1
  class class-phone
    set ip-dscp 40
    exit
  exit
policy-map pmap2
  class class-confidential
    set ip-dscp 32
    police twin-rate 20000 30000 10240 10240 yellow-action remark red-action drop
    remark-map yellow ip-dscp 8
    exit
  exit

interface port1.2
  service-policy input pmap1
  exit
interface port1.3
  service-policy input pmap2
  exit
スパニングツリーの設定 spanning-tree shutdown

設定の確認

「show policy-map」コマンドで設定を確認します。

[コンソール]
SWX2320#show policy-map

  Policy-Map Name: pmap1
    State: attached

    Class-Map Name: class-phone
      Match Access-List: 1
      Set IP DSCP: 40

  Policy-Map Name: pmap2
    State: attached

    Class-Map Name: class-confidential
      Match Access-List: 2
      Set IP DSCP: 32
      Police: Mode: TrTCM
              average rate (20000 Kbits/sec)
              peak rate (30000 Kbits/sec)
              burst size (10240 KBytes)
              peak burst size (10240 KBytes)
              yellow-action (Remark [DSCP:8])
              red-action (Drop)
[解説]
ポリシーマップ情報を確認します。
適用されているポリシーマップ「pmap1」および「pmap2」の詳細が確認できます。
コマンドの詳細は、ポリシーマップ情報の表示をご覧ください。

※上記操作による設定(Config)を取り出すことができます。



※ネットワーク機器を安全にお使いいただくために、管理パスワードの変更(スイッチ)を推奨します。


【ご注意】
本設定例は、設定の参考例を示したもので、動作を保証するものではございません。
ご利用いただく際には、十分に評価・検証を実施してください。

メール

ご相談・お問い合わせ