ネットカフェで個人ブースからの通信を制限(アイソレートVLAN) + 不正端末の接続禁止(アクセスリスト) : コマンド設定

管理番号:YMHSW-4204

本設定例の対応機種は、SWX2310P-28GTSWX2310P-18GSWX2310P-10GSWX2300-24GSWX2300-16GSWX2300-8Gです。

図 ネットカフェで個人ブースからの通信を制限(アイソレートVLAN) + 不正端末の接続禁止(アクセスリスト) : コマンド設定

ネットカフェのネットワーク環境を想定した設定例です。

個人ブースのネットワークには、「アイソレートVLAN」を使用して、個人ブースからの通信をインターネットへのアクセスだけに制限しています。個人ブース間の通信を遮断することで、ユーザーのプライバシーを守ります。また、個人ブースごとに利用可能な通信帯域の上限を設けて、公平なサービスを提供します。
管理室のネットワークには、「コミュニティVLAN」を使用して、管理室内の通信を許可するとともに、個人ブースとの通信を遮断します。
不正な端末の接続を禁止するために、MACアドレスによる「アクセスリスト」を設定して、接続可能な端末を制限しています。

技術情報:

本設定例では、以下の構成で説明します。

  • 個人ブースは、インターネットにだけ、アクセスできます。
  • 管理室内のPC1とPC2は、相互通信が可能で、それぞれインターネットアクセスできます。

ルーターの設定例

※ネットワーク機器を安全にお使いいただくために、管理パスワードの変更(ルーター)を奨励します。

ヤマハルーターの場合

ヤマハルーターを利用してインターネットに接続する場合は、以下の設定例をご利用ください。

LANインターフェースの設定
(LAN1ポートを使用)
ip lan1 address 192.168.100.1/24
WANインターフェースの設定
(LAN2ポートを使用)
ip route default gateway pp 1
pp select 1

pp always-on on
pppoe use lan2
pp auth accept pap chap
pp auth myname (ISPに接続するID) (ISPに接続するパスワード)
ppp lcp mru on 1454
ppp ipcp ipaddress on
ppp ipcp msext on
ppp ccp type none
ip pp mtu 1454
ip pp secure filter in 1020 1030 2000
ip pp secure filter out 1010 1011 1012 1013 1014 1015 3000 dynamic 100 101 102 103 104 105 106 107
ip pp nat descriptor 1
pp enable 1
フィルターの設定 ip filter source-route on
ip filter directed-broadcast on
ip filter 1010 reject * * udp,tcp 135 *
ip filter 1011 reject * * udp,tcp * 135
ip filter 1012 reject * * udp,tcp netbios_ns-netbios_ssn *
ip filter 1013 reject * * udp,tcp * netbios_ns-netbios_ssn
ip filter 1014 reject * * udp,tcp 445 *
ip filter 1015 reject * * udp,tcp * 445
ip filter 1020 reject 192.168.100.0/24 *
ip filter 1030 pass * 192.168.100.0/24 icmp
ip filter 2000 reject * *
ip filter 3000 pass * *
ip filter dynamic 100 * * ftp
ip filter dynamic 101 * * www
ip filter dynamic 102 * * domain
ip filter dynamic 103 * * smtp
ip filter dynamic 104 * * pop3
ip filter dynamic 105 * * submission
ip filter dynamic 106 * * tcp
ip filter dynamic 107 * * udp
NATの設定 nat descriptor type 1 masquerade
DHCPの設定 dhcp service server
dhcp server rfc2131 compliant except remain-silent
dhcp scope 1 192.168.100.2-192.168.100.191/24
DNSの設定 dns server pp 1
dns private address spoof on

スイッチの設定例

※ネットワーク機器を安全にお使いいただくために、管理パスワードの変更(スイッチ)を奨励します。

SWX2310Pの場合

下記の設定(Config)を取り出すことができます。

プライベートVLANの設定
# 注釈1
vlan database
  vlan 10
  vlan 20
  vlan 21
  private-vlan 10 primary
  private-vlan 20 community
  private-vlan 21 isolated
  private-vlan 10 association add 20
  private-vlan 10 association add 21
  exit
interface port1.1
  switchport mode access
  switchport access vlan 10
  switchport mode private-vlan promiscuous
  switchport private-vlan mapping 10 add 20
  switchport private-vlan mapping 10 add 21
  exit
interface port1.2
  switchport mode access
  switchport access vlan 20
  switchport mode private-vlan host
  switchport private-vlan host-association 10 add 20
  exit
interface port1.3
  switchport mode access
  switchport access vlan 20
  switchport mode private-vlan host
  switchport private-vlan host-association 10 add 20
  exit
interface port1.4
  switchport mode access
  switchport access vlan 21
  switchport mode private-vlan host
  switchport private-vlan host-association 10 add 21
  exit
interface port1.5
  switchport mode access
  switchport access vlan 21
  switchport mode private-vlan host
  switchport private-vlan host-association 10 add 21
  exit
アクセスリストの設定 access-list 2001 permit host (管理室PC1のMACアドレス) any
access-list 2001 permit host (管理室PC2のMACアドレス) any
access-list 2001 permit host (個人ブース1に接続するPCのMACアドレス) any
access-list 2001 permit host (個人ブース2に接続するPCのMACアドレス) any
access-list 2001 deny any any
interface port1.2
  access-group 2001 in
  exit
interface port1.3
  access-group 2001 in
  exit
interface port1.4
  access-group 2001 in
  exit
interface port1.5
  access-group 2001 in
  exit
QoSの設定 qos enable
access-list 1 permit any 192.168.100.0/24 any
class-map cmap1
  match access-list 1
  exit
policy-map pmap1
  class cmap1
    police single-rate 10000 62 11 yellow-action drop red-action drop
    exit
  exit
interface port1.4
  service-policy input pmap1
  exit
interface port1.5
  service-policy input pmap1
  exit

[注釈の説明]

注釈1:
必要に応じて、他のポートも設定してください。使用しないポートは、シャットダウンして、使用禁止にすることを奨励します。

設定の確認

・「show vlan private-vlan」コマンドで設定を確認します。

[コンソール]
SWX2310P#show vlan private-vlan
 PRIMARY        SECONDARY          TYPE          INTERFACES
 -------        ---------       ----------      ----------
      10              20         community       port1.2 port1.3
      10              21          isolated       port1.4 port1.5
SWX2310P#
[解説]
VLAN#20は、コミュニティVLANで、ポート2,3 がホストポートとして所属しています。
VLAN#21は、アイソレートVLANで、ポート4,5 がホストポートとして所属しています。コマンドの詳細は、プライベートVLAN情報の表示をご覧ください。

・「show access-list」コマンドで設定を確認します。

[コンソール]
SWX2310P#show access-list
IPv4 access list 1
    10 permit any 192.168.100.0 0.0.0.255 any
MAC access list 2001
    10 permit host (管理室PC1のMACアドレス) any
    20 permit host (管理室PC2のMACアドレス) any
    30 permit host (個人ブース1に接続するPCのMACアドレス) any
    40 permit host (個人ブース2に接続するPCのMACアドレス) any
    50 deny any any
SWX2310P#
[解説]
アクセスリスト ID:2001 は、登録したMACアドレスからのアクセスを許可しています(それ以外は拒否します)。コマンドの詳細は、生成した全アクセスリストの表示をご覧ください。

・「show access-group」コマンドで設定を確認します。

[コンソール]
SWX2310P#show access-group
Interface port1.2 : MAC access group 2001 in
Interface port1.3 : MAC access group 2001 in
Interface port1.4 : MAC access group 2001 in
Interface port1.5 : MAC access group 2001 in
SWX2310P#
[解説]
ポート2~5 はアクセスリスト ID:2001 がIN 方向に適用されています。
コマンドの詳細は、インターフェースに適用したアクセスリストの表示をご覧ください。

・「show policy-map」コマンドで設定を確認します。

[コンソール]
SWX2310P#show policy-map

  Policy-Map Name: pmap1
    State: attached

    Class-Map Name: cmap1
      Match Access-List: 1
      Police: Mode: SrTCM ★
              average rate (10000 Kbits/sec)
              burst size (11 KBytes)
              excess burst size (11 KBytes)
              yellow-action (Drop)
              red-action (Drop)

SWX2310P#
[解説]
生成したポリシーマップの適用と、設定したクラスマップの情報が表示されています。コマンドの詳細は、以下をご覧ください。
ポリシーマップ情報の表示 クラスマップ情報の表示
SWX2300の場合

下記の設定(Config)を取り出すことができます。

プライベートVLANの設定
# 注釈1
vlan database
  vlan 10
  vlan 20
  vlan 21
  private-vlan 10 primary
  private-vlan 20 community
  private-vlan 21 isolated
  private-vlan 10 association add 20
  private-vlan 10 association add 21
  exit
interface ge1
  switchport mode access
  switchport access vlan 10
  switchport mode private-vlan promiscuous
  switchport private-vlan mapping 10 add 20
  switchport private-vlan mapping 10 add 21
  exit
interface ge2
  switchport mode access
  switchport access vlan 20
  switchport mode private-vlan host
  switchport private-vlan host-association 10 add 20
  exit
interface ge3
  switchport mode access
  switchport access vlan 20
  switchport mode private-vlan host
  switchport private-vlan host-association 10 add 20
  exit
interface ge4
  switchport mode access
  switchport access vlan 21
  switchport mode private-vlan host
  switchport private-vlan host-association 10 add 21
  exit
interface ge5
  switchport mode access
  switchport access vlan 21
  switchport mode private-vlan host
  switchport private-vlan host-association 10 add 21
  exit
アクセスリストの設定 access-list 100 permit mac host (管理室PC1のMACアドレス) any
access-list 100 permit mac host (管理室PC2のMACアドレス) any
access-list 100 permit mac host (個人ブース1に接続するPCのMACアドレス) any
access-list 100 permit mac host (個人ブース2に接続するPCのMACアドレス) any
interface ge2
  mac access-group 100 in
  exit
interface ge3
  mac access-group 100 in
  exit
interface ge4
  mac access-group 100 in
  exit
interface ge5
  mac access-group 100 in
  exit
QoSの設定 mls qos enable
ip-access-list 1 permit 192.168.100.0 0.0.0.255
class-map cmap1
  match access-group 1
  exit
policy-map pmap1
  class cmap1
    police single-rate 10000 62 11 yellow-action drop red-action drop
    exit
  exit
interface ge4
  service-policy input pmap1
  exit
interface ge5
  service-policy input pmap1
  exit

[注釈の説明]

注釈1:
必要に応じて、他のポートも設定してください。使用しないポートは、シャットダウンして、使用禁止にすることを奨励します。

設定の確認

・「show vlan private-vlan」コマンドで設定を確認します。

[コンソール]
SWX2300#show vlan private-vlan
 PRIMARY        SECONDARY          TYPE          INTERFACES
 -------        ---------       ----------      ----------
      10              20         community       ge2 ge3
      10              21          isolated       ge4 ge5
SWX2300#
[解説]
VLAN#20は、コミュニティVLANで、ポート2,3 がホストポートとして所属しています。
VLAN#21は、アイソレートVLANで、ポート4,5 がホストポートとして所属しています。コマンドの詳細は、プライベートVLAN情報の表示をご覧ください。

・「show access-list」コマンドで設定を確認します。

[コンソール]
SWX2300#show access-list
MAC access list 100
    permit mac host (管理室PC1のMACアドレス) any
    permit mac host (管理室PC2のMACアドレス) any
    permit mac host (個人ブース1に接続するPCのMACアドレス) any
    permit mac host (個人ブース2に接続するPCのMACアドレス) any

SWX2300#
[解説]
アクセスリスト ID:100 は、登録したMACアドレスからのアクセスを許可しています(それ以外は拒否します)。コマンドの詳細は、生成した全アクセスリストの表示をご覧ください。

・「show access-group」コマンドで設定を確認します。

[コンソール]
SWX2300#show access-group
Interface ge2  : MAC access group 100 in
Interface ge3  : MAC access group 100 in
Interface ge4  : MAC access group 100 in
Interface ge5  : MAC access group 100 in
SWX2300#
[解説]
ポート2~5 はアクセスリスト ID:100 がIN 方向に適用されています。
※本コマンドは、Rev.2.00.10以降で使用できます。コマンドの詳細は、インターフェースに適用したアクセスリストの表示をご覧ください。

・「show policy-map」コマンドで設定を確認します。

[コンソール]
SWX2300#show policy-map

  Policy-Map Name: pmap1
    State: attached

    Class-Map Name: cmap1
      QoS-Access-List Name: 1
      Police: Mode: SrTCM ★
              average rate (10000 Kbits/sec)
              burst size (62 KBytes)
              excess burst size (11 KBytes)
              yellow-action (Drop)
              red-action (Drop)

SWX2300#
[解説]
生成したポリシーマップの適用と、設定したクラスマップの情報が表示されています。コマンドの詳細は、以下をご覧ください。
ポリシーマップ情報の表示 クラスマップ情報の表示

【ご注意】
本設定例は、設定の参考例を示したもので、動作を保証するものではございません。
ご利用いただく際には、十分に評価・検証を実施してください。

メール

ご相談・お問い合わせ