部門ごとにセグメントを分割(タグVLAN) : コマンド設定

管理番号:YMHSW-4366

本設定例の対応機種は、SWX2310P-28GTSWX2310P-18GSWX2310P-10GSWX2300-24GSWX2300-16GSWX2300-8Gです。

図 部門ごとにセグメントを分割(タグVLAN) : コマンド設定

インテリジェントL2スイッチのタグVLAN機能を使用して、部門ごとにセグメントを分割します。たとえば、複数のスイッチを異なる部門で共用したい場合に本設定例をご利用ください。

ポートベースVLANだけの構成で、スイッチ間を接続しようとした場合、VLANグループそれぞれに配線が必要です。
一方、タグVLANを使用すると、1つのポートに複数のVLANグループを設定できるため、スイッチ間を1つの配線で接続できます。よって、機材・配線の変更が少なく、ネットワークの変更や拡張が容易になります。
なお、異なるVLANとの通信は、ルーターを経由します。

技術情報:VLAN (SWX2310PSWX2300

本設定例では、以下の構成で説明します。

  • ルーター:LAN1にスイッチ(1)(2)を接続
    - VLAN #101のネットワークアドレス:192.168.101.0/24
    - VLAN #102のネットワークアドレス:192.168.102.0/24
  • スイッチ(1)(2)
    - ポート1:ルーターと接続。グループ1,2(VLAN #101,#102に設定)
    - ポート2~4:グループ1(VLAN #101に設定)
    - ポート5~8:グループ2(VLAN #102に設定)

ルーターの設定例

※ネットワーク機器を安全にお使いいただくために、管理パスワードの変更(ルーター)を奨励します。

ヤマハルーターの場合
LANインターフェースの設定 ip lan1 address 192.168.100.1/24
VLANの設定 vlan lan1/1 802.1q vid=101 name=VLAN101
ip lan1/1 address 192.168.101.1/24
vlan lan1/2 802.1q vid=102 name=VLAN102
ip lan1/2 address 192.168.102.1/24
DHCPの設定 dhcp service server
dhcp server rfc2131 compliant except remain-silent
dhcp scope 1 192.168.100.2-192.168.100.191/24
dhcp scope 101 192.168.101.2-192.168.101.191/24
dhcp scope 102 192.168.102.2-192.168.102.191/24

スイッチの設定例

※ネットワーク機器を安全にお使いいただくために、管理パスワードの変更(スイッチ)を奨励します。

SWX2310Pの場合

下記の設定(Config)を取り出すことができます。

設定手順

  1. ユーザモードから特権EXECモードに移行します。
    [コンソール]
    SWX2310P>enable
    SWX2310P#
    
  2. グローバルコンフィグレーションモードに移行します。
    [コンソール]
    SWX2310P#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    SWX2310P(config)#
    
  3. VLANを定義します。
    [コンソール]
    SWX2310P(config)#vlan database
    SWX2310P(config-vlan)#vlan 101
    SWX2310P(config-vlan)#vlan 102
    SWX2310P(config-vlan)#exit
    SWX2310P(config)#
    
  4. ポート1をトランクポートに設定し、VLAN #101 / #102 に所属させます。
    [コンソール]
    SWX2310P(config)#interface port1.1
    SWX2310P(config-if)#switchport mode trunk
    SWX2310P(config-if)#switchport trunk allowed vlan add 101
    SWX2310P(config-if)#switchport trunk allowed vlan add 102
    SWX2310P(config-if)#exit
    SWX2310P(config)#
    
  5. ポート2~4をアクセスポートに設定し、VLAN #101 に所属させます。
    [コンソール]
    SWX2310P(config)#interface port1.2
    SWX2310P(config-if)#switchport mode access
    SWX2310P(config-if)#switchport access vlan 101
    SWX2310P(config-if)#exit
    SWX2310P(config)#interface port1.3
    SWX2310P(config-if)#switchport mode access
    SWX2310P(config-if)#switchport access vlan 101
    SWX2310P(config-if)#exit
    SWX2310P(config)#interface port1.4
    SWX2310P(config-if)#switchport mode access
    SWX2310P(config-if)#switchport access vlan 101
    SWX2310P(config-if)#exit
    SWX2310P(config)#
    
  6. ポート5~8をアクセスポートに設定し、VLAN #102 に所属させます。
    [コンソール]
    SWX2310P(config)#interface port1.5
    SWX2310P(config-if)#switchport mode access
    SWX2310P(config-if)#switchport access vlan 102
    SWX2310P(config-if)#exit
    SWX2310P(config)#interface port1.6
    SWX2310P(config-if)#switchport mode access
    SWX2310P(config-if)#switchport access vlan 102
    SWX2310P(config-if)#exit
    SWX2310P(config)#interface port1.7
    SWX2310P(config-if)#switchport mode access
    SWX2310P(config-if)#switchport access vlan 102
    SWX2310P(config-if)#exit
    SWX2310P(config)#interface port1.8
    SWX2310P(config-if)#switchport mode access
    SWX2310P(config-if)#switchport access vlan 102
    SWX2310P(config-if)#exit
    SWX2310P(config)#
    

設定内容

VLANの設定 vlan database
  vlan 101
  vlan 102
  exit
interface port1.1
  switchport mode trunk
  switchport trunk allowed vlan add 101
  switchport trunk allowed vlan add 102
  exit
interface port1.2
  switchport mode access
  switchport access vlan 101
  exit
interface port1.3
  switchport mode access
  switchport access vlan 101
  exit
interface port1.4
  switchport mode access
  switchport access vlan 101
  exit
interface port1.5
  switchport mode access
  switchport access vlan 102
  exit
interface port1.6
  switchport mode access
  switchport access vlan 102
  exit
interface port1.7
  switchport mode access
  switchport access vlan 102
  exit
interface port1.8
  switchport mode access
  switchport access vlan 102
  exit

設定の確認

「show vlan」コマンドで設定を確認します。

[コンソール]
SWX2310P#show vlan brief
(u)-Untagged, (t)-Tagged

VLAN ID  Name                            State   Member ports
======= ================================ ======= =======================
1       default                          ACTIVE  port1.1(u) port1.9(u)
                                                 port1.10(u)
101     VLAN0101                         ACTIVE  port1.1(t) port1.2(u)
                                                 port1.3(u) port1.4(u)
102     VLAN0102                         ACTIVE  port1.1(t) port1.5(u)
                                                 port1.6(u) port1.7(u)
                                                 port1.8(u)

SWX2310P#
[解説]
ポート1は、 タグ付きポート(t)として、VLAN #101, #102に所属しています。
VLAN #101には、タグなしポート(u)として、ポート2, 3, 4 が所属しています。
VLAN #102には、タグなしポート(u)として、ポート5, 6, 7, 8 が所属しています。 コマンドの詳細は、VLAN情報の表示をご覧ください。
SWX2300の場合

下記の設定(Config)を取り出すことができます。

設定手順

  1. ユーザモードから特権EXECモードに移行します。
    [コンソール]
    SWX2300>enable
    SWX2300#
    
  2. グローバルコンフィグレーションモードに移行します。
    [コンソール]
    SWX2300#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    SWX2300(config)#
    
  3. VLANを定義します。
    [コンソール]
    SWX2300(config)#vlan database
    SWX2300(config-vlan)#vlan 101
    SWX2300(config-vlan)#vlan 102
    SWX2300(config-vlan)#exit
    SWX2300(config)#
    
  4. ポート1をトランクポートに設定し、VLAN #101 / #102 に所属させます。
    [コンソール]
    SWX2300(config)#interface ge1
    SWX2300(config-if)#switchport mode trunk
    SWX2300(config-if)#switchport trunk allowed vlan add 101
    SWX2300(config-if)#switchport trunk allowed vlan add 102
    SWX2300(config-if)#exit
    SWX2300(config)#
    
  5. ポート2~4をアクセスポートに設定し、VLAN #101 に所属させます。
    [コンソール]
    SWX2300(config)#interface ge2
    SWX2300(config-if)#switchport mode access
    SWX2300(config-if)#switchport access vlan 101
    SWX2300(config-if)#exit
    SWX2300(config)#interface ge3
    SWX2300(config-if)#switchport mode access
    SWX2300(config-if)#switchport access vlan 101
    SWX2300(config-if)#exit
    SWX2300(config)#interface ge4
    SWX2300(config-if)#switchport mode access
    SWX2300(config-if)#switchport access vlan 101
    SWX2300(config-if)#exit
    SWX2300(config)#
    
  6. ポート5~8をアクセスポートに設定し、VLAN #102 に所属させます。
    [コンソール]
    SWX2300(config)#interface ge5
    SWX2300(config-if)#switchport mode access
    SWX2300(config-if)#switchport access vlan 102
    SWX2300(config-if)#exit
    SWX2300(config)#interface ge6
    SWX2300(config-if)#switchport mode access
    SWX2300(config-if)#switchport access vlan 102
    SWX2300(config-if)#exit
    SWX2300(config)#interface ge7
    SWX2300(config-if)#switchport mode access
    SWX2300(config-if)#switchport access vlan 102
    SWX2300(config-if)#exit
    SWX2300(config)#interface ge8
    SWX2300(config-if)#switchport mode access
    SWX2300(config-if)#switchport access vlan 102
    SWX2300(config-if)#exit
    SWX2300(config)#
    

設定内容

VLANの設定 vlan database
  vlan 101
  vlan 102
  exit
interface ge1
  switchport mode trunk
  switchport trunk allowed vlan add 101
  switchport trunk allowed vlan add 102
  exit
interface ge2
  switchport mode access
  switchport access vlan 101
  exit
interface ge3
  switchport mode access
  switchport access vlan 101
  exit
interface ge4
  switchport mode access
  switchport access vlan 101
  exit
interface ge5
  switchport mode access
  switchport access vlan 102
  exit
interface ge6
  switchport mode access
  switchport access vlan 102
  exit
interface ge7
  switchport mode access
  switchport access vlan 102
  exit
interface ge8
  switchport mode access
  switchport access vlan 102
  exit

設定の確認

「show vlan」コマンドで設定を確認します。

[コンソール]
SWX2300#show vlan brief
(u)-Untagged, (t)-Tagged

VLAN ID  Name                            State   Member ports
======= ================================ ======= ======================
1       default                          ACTIVE  ge1(u) ge9(u)
101     VLAN0101                         ACTIVE  ge1(t) ge2(u) ge3(u)
                                                 ge4(u)
102     VLAN0102                         ACTIVE  ge1(t) ge5(u) ge6(u)
                                                 ge7(u) ge8(u)
SWX2300#
[解説]
ポート1は、 タグ付きポート(t)として、VLAN #101, #102に所属しています。
VLAN #101には、タグなしポート(u)として、ポート2, 3, 4 が所属しています。
VLAN #102には、タグなしポート(u)として、ポート5, 6, 7, 8 が所属しています。 コマンドの詳細は、VLAN情報の表示をご覧ください。

【ご注意】
本設定例は、設定の参考例を示したもので、動作を保証するものではございません。
ご利用いただく際には、十分に評価・検証を実施してください。