大規模ネットワーク構成(スタックとリンクアグリゲーションによる冗長化) : SWX3200 コマンド設定

管理番号:YMHSW-16483

本設定例の対応機種は、 SWX3200-52GTSWX3200-28GTSWX2310P-28GTSWX2300-24GSWX2300-16GSWX2300-8Gです。

図 構成図

大企業のネットワーク環境を想定した設定例です。

全体を管理するコアスイッチにSWX3200、各部門を管理するエッジスイッチにSWX2300を配置しています。また、サーバールーム用のエッジスイッチとして、SWX2310P-28GTを配置しています。

SWX3200のスタック機能を利用して、2台のスイッチを仮想的な1台のスイッチとして動作させています。SWX3200(1)で、コアスイッチのすべてのポートに対して、設定と設定の確認を行います。
さらに、各エッジスイッチとの接続にリンクアグリケーション機能を併用しています。スイッチ間を接続する複数のポートを束ねて、1つの論理インターフェースとして扱います。束ねたうちの1つのポートで障害が発生し、通信不可になった場合でも、残りのポートで通信を継続できます。

技術情報: スタック機能VLANリンクアグリケーションDHCPサーバースタティックルーティング

本設定例では、以下の構成で説明します。

  • コアスイッチ SWX3200-52GT
    - ポート1.1, ポート2.1:ルーターと接続 (論理インターフェース#1)
    - ポート1.2, ポート2.2:VLAN #11, VLAN#12 (論理インターフェース#2)
      - VLAN#11
          IPアドレス:192.168.101.1
          ネットワークアドレス:192.168.101.0/24
          DHCPプール:192.168.101.2~192.168.101.191
      - VLAN#12
          IPアドレス:192.168.102.1
          ネットワークアドレス:192.168.102.0/24
          DHCPプール:192.168.102.2~192.168.102.191
    - ポート1.49, ポート2.49(SFP+ポート ※):VLAN #20 (論理インターフェース#3)
         IPアドレス:192.168.103.1
  • エッジスイッチ SWX2300-24G
    - ポート2, ポート3:VLAN #11, VLAN#12 (論理インターフェース#2)
    - ポート5:VLAN #11
    - ポート6:VLAN #12
  • エッジスイッチ SWX2310-28GT
    - ポート27, ポート28(SFP+ポート):VLAN #20 (論理インターフェース#3)
    - ポート1, ポート2:VLAN #20

※SFP+ポートのポート番号は、機種によって異なります。ご注意ください。
 本設定例では、SWX3200-52GTを例に説明します。
 SWX3200-28GTをご利用の場合は、ポート25~26をご利用ください。

※スイッチでSFP+ポートを利用するには、別途、以下の機材が必要です。
  ・SFP+ポートとして利用する場合:
   ・SFP+モジュール (YSFP-G-SXAYSFP-G-LXAYSFP-10G-SRYSFP-10G-LR のいずれか)
  ・スタックポートとして利用する場合:
   ・ダイレクトアタッチケーブル (YDAC-10G-1MYDAC-10G-3M のいずれか)
  または
   ・SFP+モジュール (YSFP-G-SXAYSFP-G-LXAYSFP-10G-SRYSFP-10G-LR のいずれか)

事前準備

スタックの初期設定 および 光ファイバーケーブルの装着

  1. 2台のSWX3200-52GTと、SWX2310P-28GTの電源を切ります。
  2. 各スイッチのSFP+ポートを、以下のとおりに接続します。
    接続元のポート 接続先のポート 使用する機材
    1 コアスイッチ SWX3200-52GT(1) の ポート51 コアスイッチ SWX3200-52GT(2) の ポート52 ダイレクトアタッチケーブル (*1)

    または
    SFP+モジュール (*2)、および 光ファイバーケーブル
    2 コアスイッチ SWX3200-52GT(1) の ポート52 コアスイッチ SWX3200-52GT(2) の ポート51
    3 コアスイッチ SWX3200-52GT(1) の ポート49 エッジスイッチ SWX2310P-28GT の ポート27 SFP+モジュール (*2)、および 光ファイバーケーブル
    4 コアスイッチ SWX3200-52GT(2) の ポート49 エッジスイッチ SWX2310P-28GT の ポート28

    (*1) ダイレクトアタッチケーブルの詳しい取り付け方法については、取扱説明書をご覧ください。
    (*2) SFP+モジュールの詳しい取り付け方法については、取扱説明書(YSFP-G-SXA、YSFP-G-LXAYSFP-10G-SR、YSFP-10G-LR)をご覧ください。

  3. 2台のSWX3200-52GTと、SWX2310P-28GTの電源を入れます。
  4. 2台のSWX3200-52GTのファームウェアバージョンが等しいことを確認します。
    [コンソール]
    SWX3200#show environment
    SWX3200-52GT BootROM Ver.1.00
    SWX3200-52GT Rev.4.00.xx (Fri Jul  6 10:15:46 2018)
    main=SWX3200-52GT ver=00 serial=Z0000000XX MAC-Address=0000.0000.0000
    ・・・
    
  5. コアスイッチ SWX3200-52GT(1) のスタック機能を有効にします。
    [コンソール]
    SWX3200(config)#stack enable
    reset configuration and reboot system? (y/n):y
    
  6. コアスイッチ SWX3200-52GT(2) のスタックIDを変更し、スタック機能を有効にします。
    [コンソール]
    SWX3200(config)#stack 1 renumber 2
    SWX3200(config)#stack enable
    reset configuration and reboot system? (y/n):y
    
  7. 「show stack」でスタック情報を確認します。
    [コンソール]
    SWX3200#show stack
    Stack: Enable
    
    Configured ID: 1
    Running ID   : 1
    Status       : Active
    
    ID  Model          Status      Role
    -------------------------------------
    1   SWX3200-52GT   Active      Master
    2   SWX3200-52GT   Active      Slave
    SWX3200#
    
    [解説]
    スタック情報を表示します。
    スタック ID:1のSWX3200-52GTがマスター、スタック ID:2 のSWX3200-52GTがスレーブで動作しています。スタック IDは、SWX3200-52GTの前面の「スタック ID表示ランプ」でも確認できます。
    コマンドの詳細は、スタック情報の表示をご覧ください。

コアスイッチ SWX3200の設定例

※ネットワーク機器を安全にお使いいただくために、管理パスワードの変更(L3スイッチ)を奨励します。

下記の設定(Config)を取り出すことができます。

VLANインターフェースの設定
# 注釈1
vlan database
  vlan 11
  vlan 12
  vlan 20
  exit

interface vlan11
  ip address 192.168.101.1/24
  exit
interface vlan12
  ip address 192.168.102.1/24
  exit
interface vlan20
  ip address 192.168.103.1/24
  auto-ip disable
  exit

interface port1.2
  switchport mode trunk
  switchport trunk allowed vlan add 11,12
  exit
interface port2.2
  switchport mode trunk
  switchport trunk allowed vlan add 11,12
  exit
interface port1.49
  switchport mode access
  switchport access vlan 20
  exit
interface port2.49
  switchport mode access
  switchport access vlan 20
  exit
リンクアグリゲーションの設定 interface port1.1
  static-channel-group 1
  exit
interface port2.1
  static-channel-group 1
  exit
interface port1.2
  static-channel-group 2
  exit
interface port2.2
  static-channel-group 2
  exit
interface port1.49
  static-channel-group 3
  exit
interface port2.49
  static-channel-group 3
  exit

interface sa1
  no shutdown
  exit
interface sa2
  no shutdown
  exit
interface sa3
  no shutdown
  exit
DHCPサーバーの設定 interface vlan11
  dhcp-server enable
  exit
interface vlan12
  dhcp-server enable
  exit

dhcp pool vlan11
  network 192.168.101.0/24
  range 192.168.101.2 192.168.101.191
  default-router 192.168.101.1
  dns-server 192.168.100.1
  exit
dhcp pool vlan12
  network 192.168.102.0/24
  range 192.168.102.2 192.168.102.191
  default-router 192.168.102.1
  dns-server 192.168.100.1
  exit

dhcp-server enable
ゲートウェイの設定 ip route 0.0.0.0/0 192.168.100.1

[注釈の説明]

注釈1:
必要に応じて、他のポートも設定してください。使用しないポートは、シャットダウンして、使用禁止にすることを奨励します。

エッジスイッチ SWX2310P-28GTの設定例

※ネットワーク機器を安全にお使いいただくために、管理パスワードの変更(L2スイッチ)を奨励します。

VLANインターフェースの設定
# 注釈2
vlan database
  vlan 20
  exit

interface port1.1
  switchport mode access
  switchport access vlan 20
  exit
interface port1.2
  switchport mode access
  switchport access vlan 20
  exit
interface port1.27
  switchport mode access
  switchport access vlan 20
  exit
interface port1.28
  switchport mode access
  switchport access vlan 20
  exit
リンクアグリゲーションの設定 interface port1.27
  static-channel-group 3
  exit
interface port1.28
  static-channel-group 3
  exit

interface sa3
  no shutdown
  exit

[注釈の説明]

注釈2:
必要に応じて、他のポートも設定してください。使用しないポートは、シャットダウンして、使用禁止にすることを奨励します。

エッジスイッチ SWX2300の設定例

※ネットワーク機器を安全にお使いいただくために、管理パスワードの変更(L2スイッチ)を奨励します。

下記の設定(Config)を取り出すことができます。

VLANインターフェースの設定
# 注釈3
vlan database
  vlan 11
  vlan 12
  exit

interface ge2
  switchport mode trunk
  switchport trunk allowed vlan add 11,12
  exit
interface ge3
  switchport mode trunk
  switchport trunk allowed vlan add 11,12
  exit
interface ge5
  switchport mode access
  switchport access vlan 11
  exit
interface ge6
  switchport mode access
  switchport access vlan 12
  exit
リンクアグリゲーションの設定 interface ge2
  static-channel-group 2
  exit
interface ge3
  static-channel-group 2
  exit

interface sa2
  no shutdown
  exit

[注釈の説明]

注釈3:
必要に応じて、他のポートも設定してください。使用しないポートは、シャットダウンして、使用禁止にすることを奨励します。

ルーターの設定例

ヤマハルーターを利用してインターネットに接続する場合は、以下の設定例をご利用ください。
※ネットワーク機器を安全にお使いいただくために、管理パスワードの変更(ルーター)を奨励します。

ゲートウェイの設定 ip route default gateway pp 1
ip route 192.168.0.0/16 gateway 192.168.100.240
LANインターフェースの設定
(LAN1ポートを使用)
ip lan1 address 192.168.100.1/24
リンクアグリケーションの設定 lan link-aggregation static 1 lan1:1 lan1:2
WANインターフェースの設定
(LAN2ポートを使用)
pp select 1
pp always-on on
pppoe use lan2
pp auth accept pap chap
pp auth myname (ISPに接続するID) (ISPに接続するパスワード)
ppp lcp mru on 1454
ppp ipcp ipaddress on
ppp ipcp msext on
ppp ccp type none
ip pp mtu 1454
ip pp secure filter in 1020 1030 2000
ip pp secure filter out 1010 1011 1012 1013 1014 1015 3000 dynamic 100 101 102 103 104 105 106 107
ip pp nat descriptor 1
pp enable 1
フィルターの設定 ip filter source-route on
ip filter directed-broadcast on
ip filter 1010 reject * * udp,tcp 135 *
ip filter 1011 reject * * udp,tcp * 135
ip filter 1012 reject * * udp,tcp netbios_ns-netbios_ssn *
ip filter 1013 reject * * udp,tcp * netbios_ns-netbios_ssn
ip filter 1014 reject * * udp,tcp 445 *
ip filter 1015 reject * * udp,tcp * 445
ip filter 1020 reject 192.168.0.0/16 *
ip filter 1030 pass * 192.168.0.0/16 icmp
ip filter 2000 reject * *
ip filter 3000 pass * *
ip filter dynamic 100 * * ftp
ip filter dynamic 101 * * www
ip filter dynamic 102 * * domain
ip filter dynamic 103 * * smtp
ip filter dynamic 104 * * pop3
ip filter dynamic 105 * * submission
ip filter dynamic 106 * * tcp
ip filter dynamic 107 * * udp
NATの設定 nat descriptor type 1 masquerade
DNSの設定 dns host any
dns server (ISPから指定されたDNSサーバーのIPアドレス)
dns private address spoof on

設定の確認

・「show vlan brief」コマンドで設定を確認します。

[コンソール]
SWX3200#show vlan brief
(u)-Untagged, (t)-Tagged

VLAN ID  Name                            State   Member ports
======= ================================ ======= =======================
1       default                          ACTIVE  port1.1(u) port1.2(u)
                                                 port1.3(u) port1.4(u)
                                                 port1.5(u) port1.6(u)
                                                 port1.7(u) port1.8(u)
                                                 port1.9(u) port1.10(u)
                                                 port1.11(u) port1.12(u)
                                                 port1.13(u) port1.14(u)
                                                 port1.15(u) port1.16(u)
                                                 port1.17(u) port1.18(u)
                                                 port1.19(u) port1.20(u)
                                                 port1.21(u) port1.22(u)
                                                 port1.23(u) port1.24(u)
                                                 port1.25(u) port1.26(u)
                                                 port1.27(u) port1.28(u)
                                                 port1.29(u) port1.30(u)
                                                 port1.31(u) port1.32(u)
                                                 port1.33(u) port1.34(u)
                                                 port1.35(u) port1.36(u)
                                                 port1.37(u) port1.38(u)
                                                 port1.39(u) port1.40(u)
                                                 port1.41(u) port1.42(u)
                                                 port1.43(u) port1.44(u)
                                                 port1.45(u) port1.46(u)
                                                 port1.47(u) port1.48(u)
                                                 port1.50(u) port2.1(u)
                                                 port2.2(u) port2.3(u)
                                                 port2.4(u) port2.5(u)
                                                 port2.6(u) port2.7(u)
                                                 port2.8(u) port2.9(u)
                                                 port2.10(u) port2.11(u)
                                                 port2.12(u) port2.13(u)
                                                 port2.14(u) port2.15(u)
                                                 port2.16(u) port2.17(u)
                                                 port2.18(u) port2.19(u)
                                                 port2.20(u) port2.21(u)
                                                 port2.22(u) port2.23(u)
                                                 port2.24(u) port2.25(u)
                                                 port2.26(u) port2.27(u)
                                                 port2.28(u) port2.29(u)
                                                 port2.30(u) port2.31(u)
                                                 port2.32(u) port2.33(u)
                                                 port2.34(u) port2.35(u)
                                                 port2.36(u) port2.37(u)
                                                 port2.38(u) port2.39(u)
                                                 port2.40(u) port2.41(u)
                                                 port2.42(u) port2.43(u)
                                                 port2.44(u) port2.45(u)
                                                 port2.46(u) port2.47(u)
                                                 port2.48(u) port2.50(u)
                                                 sa1(u) sa2(u)
11      VLAN0011                         ACTIVE  port1.2(t) port2.2(t)
                                                 sa2(t)
12      VLAN0012                         ACTIVE  port1.2(t) port2.2(t)
                                                 sa2(t)
20      VLAN0020                         ACTIVE  port1.49(u) port2.49(u)
                                                 sa3(u)

SWX3200#
[解説]
すべてのVLAN情報を表示します。
VLAN ID#11と VLAN ID#12に、スタック ID:1のポート2、スタック ID:2のポート2、論理インターフェース#2 が所属しています。
VLAN ID#20 に、スタック ID:1のポート49、 スタック ID:2のポート49、論理インターフェース#3 が所属しています。
それ以外のポートは、VLAN ID#1(デフォルトVLAN)に所属しています。
コマンドの詳細は、VLAN情報の表示をご覧ください。

・「show ip route」コマンドで設定を確認します。

[コンソール]
SWX3200#show ip route
Codes: C - connected, S - static, R - RIP
       O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       * - candidate default

Gateway of last resort is 192.168.100.1 to network 0.0.0.0

S*      0.0.0.0/0 [1/0] via 192.168.100.1, vlan1
C       192.168.100.0/24 is directly connected, vlan1
C       192.168.101.0/24 is directly connected, vlan11
C       192.168.102.0/24 is directly connected, vlan12
C       192.168.103.0/24 is directly connected, vlan20
SWX3200#
[解説]
経路の情報を表示します。
静的経路で設定したデフォルトゲートウェイは、192.168.100.1 です。また、各VLANに機器が接続されていることを示しています。
コマンドの詳細は、IPv4転送表の表示をご覧ください。

・「show dhcp binding」コマンドで設定を確認します。

[コンソール]
SWX3200#show dhcp binding
Pool vlan11 Network 192.168.101.0/24
DHCP Client Entries
IP Address       MacAddr            Type     Expiry
------------------------------------------------------------------
192.168.101.2    (MACアドレス1)     Dynamic  2018/07/25 11:49:31

Pool vlan12 Network 192.168.102.0/24
DHCP Client Entries
IP Address       MacAddr            Type     Expiry
------------------------------------------------------------------
192.168.102.2    (MACアドレス2)     Dynamic  2018/07/25 11:49:35

SWX3200#
[解説]
DHCPクライアントへのIPアドレス割り当て情報を表示します。
192.168.101.0/24のネットワークにおいて、(MACアドレス1)のクライアントには、192.168.101.2 が割り当てられています。
192.168.102.0/24のネットワークにおいて、(MACアドレス2)のクライアントには、192.168.102.2 が割り当てられています。
コマンドの詳細は、DHCPクライアントへのIPアドレス割り当て情報の表示をご覧ください。

・「show static-channel-group」コマンドで設定を確認します。

[コンソール]
SWX3200#show static-channel-group
% Static Aggregator: sa1
% Load balancing: src-dst-mac
% Member:
   port1.1
   port2.1
% Static Aggregator: sa2
% Load balancing: src-dst-mac
% Member:
   port1.2
   port2.2
% Static Aggregator: sa3
% Load balancing: src-dst-mac
% Member:
   port1.49
   port2.49
SWX3200#
[解説]
スタティック論理インターフェースの状態を表示します。
論理インターフェース#1 には、メンバーとして、スタック ID:1のポート1、スタック ID:2のポート1 が所属しています。
論理インターフェース#2 には、メンバーとして、スタック ID:1のポート2、スタック ID:2のポート2 が所属しています。
論理インターフェース#3 には、メンバーとして、スタック ID:1のポート49、スタック ID:2のポート49 が所属しています。
コマンドの詳細は、スタティック論理インターフェースの状態表示をご覧ください。

・「show interface」コマンドで設定を確認します。

[コンソール]
SWX3200#show interface sa1
Interface sa1
  Link is UP ★
  Hardware is AGGREGATE ★
  ifIndex 4501, MRU 1522
  Vlan info :
    Switchport mode        : access
    Ingress filter         : enable
    Acceptable frame types : all
    Default Vlan           :    1
    Configured Vlans       :    1
  Interface counter:
    input  packets          : 162546
           bytes            : 208213774
           multicast packets: 2
    output packets          : 98796
           bytes            : 11152242
           multicast packets: 1384
           broadcast packets: 13
           drop packets     : 0
SWX3200#
[解説]
論理インターフェース #1の状態を表示します。
論理インターフェース #1は、リンクアップしています。同様に、論理インターフェース #2,#3の状態も確認できます。
コマンドの詳細は、インターフェースの状態表示をご覧ください。

【ご注意】
本設定例は、設定の参考例を示したもので、動作を保証するものではございません。
ご利用いただく際には、十分に評価・検証を実施してください。